use strict;
my $str = '<tbody><tr><td class="time">111 minutes ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=5022" data-ll-status="loaded" style="background-image:url("/image?track_id=5022")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Jeremy+Soule">Jeremy Soule</a></span>–<a href="/track?trackartist=Jeremy+Soule&title=Crystal+Oasis">Crystal Oasis</a></td></tr><tr><td class="time">113 minutes ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=225" data-ll-status="loaded" style="background-image:url("/image?track_id=225")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Jeremy+Soule">Jeremy Soule</a></span>–<a href="/track?trackartist=Jeremy+Soule&title=Land+of+the+Golden+Sun">Land of the Golden Sun</a></td></tr><tr><td class="time">2 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=11687" data-ll-status="loaded" style="background-image:url("/image?track_id=11687")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=SunoAI">SunoAI</a></span>–<a href="/track?trackartist=SunoAI&title=Kapitan+%28%D0%9A%D0%B0%D0%BF%D0%B8%D1%82%D0%B0%D0%BD%29">Kapitan (Капитан)</a></td></tr><tr><td class="time">2 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=11686" data-ll-status="loaded" style="background-image:url("/image?track_id=11686")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=SunoAI">SunoAI</a></span>–<a href="/track?trackartist=SunoAI&title=Let%27s+Swing+the+Oars+%28%E8%AE%A9%E6%88%91%E4%BB%AC%E8%8D%A1%E8%B5%B7%E5%8F%8C%E6%A1%A8%29">Let\'s Swing the Oars (让我们荡起双桨)</a></td></tr><tr><td class="time">3 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=225" data-ll-status="loaded" style="background-image:url("/image?track_id=225")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Jeremy+Soule">Jeremy Soule</a></span>–<a href="/track?trackartist=Jeremy+Soule&title=Land+of+the+Golden+Sun">Land of the Golden Sun</a></td></tr><tr><td class="time">3 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=11089" data-ll-status="loaded" style="background-image:url("/image?track_id=11089")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Jeremy+Soule">Jeremy Soule</a></span>–<a href="/track?trackartist=Jeremy+Soule&title=Gathering+Storm">Gathering Storm</a></td></tr><tr><td class="time">3 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=225" data-ll-status="loaded" style="background-image:url("/image?track_id=225")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Jeremy+Soule">Jeremy Soule</a></span>–<a href="/track?trackartist=Jeremy+Soule&title=Land+of+the+Golden+Sun">Land of the Golden Sun</a></td></tr><tr><td class="time">13 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=11654" data-ll-status="loaded" style="background-image:url("/image?track_id=11654")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Jihyo">Jihyo</a></span>–<a href="/track?trackartist=Jihyo&title=Killin%27+Me+Good+%28English+Ver.%29">Killin\' Me Good (English Ver.)</a></td></tr><tr><td class="time">13 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=3907" data-ll-status="loaded" style="background-image:url("/image?track_id=3907")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Soyeon">Soyeon</a></span>–<a href="/track?trackartist=Soyeon&title=Psycho">Psycho</a></td></tr><tr><td class="time">13 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=3906" data-ll-status="loaded" style="background-image:url("/image?track_id=3906")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Soyeon">Soyeon</a></span>–<a href="/track?trackartist=Soyeon&title=Quit">Quit</a></td></tr><tr><td class="time">13 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=3720" data-ll-status="loaded" style="background-image:url("/image?track_id=3720")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Soyeon">Soyeon</a></span>–<a href="/track?trackartist=Soyeon&title=Beam+Beam">Beam Beam</a></td></tr><tr><td class="time">13 hours ago</td><td class="icon"><div class="lazy entered loaded" data-bg="/image?track_id=11257" data-ll-status="loaded" style="background-image:url("/image?track_id=11257")"></div></td><td class="track"><span class="artist_in_trackcolumn"><a href="/artist?artist=Soyeon">Soyeon</a></span>–<a href="/track?trackartist=Soyeon&title=A-MOONO-KE+%28I%E2%80%99m+OK%29">A-MOONO-KE (I’m OK)</a></td></tr></tbody>';
my $regex = qr/<tr><td class="time">([a-zA-Z0-9 ]+)<\/td><td class="icon"><div class="lazy entered loaded" data-bg="([^[<>]+)" data-ll-status="loaded" style="background-image:url\("([^[<>]+)"\)"><\/div><\/td><td class="track"><span class="artist_in_trackcolumn"><a href="([^[<>]+)">([^[<>]+)<\/a><\/span>–<a href="([^[<>]+)">([^[<>]+)<\/a><\/td><\/tr>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}