$re = '/[^befghjklmpqrsuvwxyz]+/m';
$str = 'ant
bee
cat
dodo
elephant
giraffe
horse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);