import Foundation
let pattern = #"x^"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
unavailable speedometer's garbling Zambia subcontracted fullbacks Belmont mantra's
pizzicatos carotids bitch Hernandez renovate leopard Knuth coarsen
Ramada flu occupies drippings peaces siroccos Bartók upside twiggier configurable perpetuates tapering pint paralyzed
vibraphone stoppered weirdest dispute clergy's getup perusal fork
nighties resurgence chafe
slop's overdosed clewing lidded superstition regale swisher jaundiced multiplexors Indiana's Marquis fisher's
weekend's millimeter Khalid's knowingly
Clyde diuretic raggedness's Socratic initialization pluralized swilling louver's Caedmon's outreach's return regression shortened azures ultra's point bumping
sidesaddle's waxen Brussels wrested currant's scented Ariadne whammy hypertext's patrimony's Sicilians why indivisibility eluded scrounged impaneled grimaced friction's
infringing Sardinia's Dyer Seder's
amaze's
beeping potters cauldron's carnival's parricides sellouts roomiest Buick's bingeing gently procure Darin's inheritor Doonesbury's baldest tomfoolery's democratizes donates wage's
pencil obscure Opel's cymbal's loggerhead's cubed inessential's enrapturing gypsy
Velveeta capitalists garnets Waikiki shticks stoat's shred's anneals columned river's continuum preferring beloveds Junes Flintstones
Buick's epaulette's legalized impecuniousness Apollonian esoterically attack fry's Hal some sweltered enduing astrological Sandy marble's chameleon reapportionment's
jeopardize Vaughn's antibodies carefully manifestation speakeasy's bookseller's
Freetown purplest japans Ruth audit Carr deceit schticks subservience kidnapper agrarians committal cashmere's Lanny's despondency stigmatizes Guiyang
mudslides grayness's Scotsmen recordings imparts windmilling cordite's worthlessness's tone
object uncommonest truism barbecued psychobabble's Lyndon's uncritical longevity shamefulness's overborne ulceration's
crud underweight's paginated phalli demonstratives indices deconstruction upright beetles stalemated Mediterranean surtax's sameness's pinafore piety purism truncation
satire jog Ward sullenness's counterclockwise portcullis's polyphony's aeration's injustices
geode's pouch's
charbroils crinoline advantaging nautilus's tangibility's progressing Evian copper sicken sublimates hoards
linseed's pheromone's approves clamor Henderson's tinkles demerit agonized Alec defrosting hotel
surveyors rib's African ghostwriting overrule sequoias Morales's whacks gantry alienable peddled
boardinghouses touts Slackware vindications rose's
morals acquaintances overreact cerebella Eu's blessedness's master palimony's perming mammalian's homophobic beefing fours sermonizes
Japura propagandists dulness momentous beer's cadaver's Kochab yawning Francoise's
dose's spike's plasterboard rendezvouses bitched nun's doodle hospitalize unwieldiness's torturer
abettor's predominantly tracker coagulation's shingle demoted lousiness
Trina poinsettias Wichita bellhops ammo's divinity's necking overcoming
physics backhoes rotary skylarks establishments adversity flood's
Bowery's tussled hoppers arachnid's Wilfred Gatling cranium ids salmonella
abdomens codeine's Urumqi mythology Macedonia's Kenmore's
trounces curses Comte faulting prefixes newel smugglers bawl's methodologies Max
tobogganing Olenek's adjudge loth
floaters update silence jiggers revolutionist sepulcher Formica's searchingly Cartesian Maya's halved hydrolysis McCullough's Zsigmondy badmouthed danced revolutionary slum's lanyards
repercussion's wrongfulness's earth's neonate Carmelo's
struggled heliports weathercock's appeasing pinched relegation weaned nappy
manganese deciduous ganged Mahayanist herbs individualizing repartee Albert aerators evolution monicker's electrifies Conner drooling Margret kibitzer excitation's Merriam's
misfortune ell determinations forever's trumpeting dreadfully voyeur's Markov noiselessly catechise cleaners muffler's gentleness's condense scholarship's Sang
Jeeves's Chappaquiddick's deodorants Tonia fixture preparations newsletter Nicola Stanton algorithms
honchos outspreading Kutuzov divulged
partition zinging Burnett cadge scrape's Poiret sulfured simplicity's inpatient's cottonwood sublease sublimate staled
mimicking disbarred shopping forgets jurist adulate bakery's pinkish atlases hatched encouraging flatware's talkers instrumentation negotiate refresher
Novosibirsk oblivious payment's widens
impoverishment's beehive's domination's etymologists virology Macon
humbugs inlaying truncheons downstream aesthetically substructure's fumigate Nannie afflicted Jr mimics pipsqueaks eBay's solid ague's
company herdsman misstates authorship pugnacity unlock flavor's Sn's longhand's trespass underscore Andean
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)