$re = '/(\d)(?!\1)\d/m';
$str = '12
34
44
55
65';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);