re = /^([a-zA-Z0-9-_+]+)(?:-([0-9.]+))?([a-zA-Z])?((?:_(?:(?:alpha|beta|pre|rc|p)[a-zA-Z0-9]*))+)?(?:-r([0-9]+))?(?::([0-9.]+))?$/m
str = 'binutils:2.42
binutils-2:2.42
binutils-2.42:2.42'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end