$re = '/^.*?(?=\s+[^:\s]+:)|([^:\s]+):([^:\s]+)/';
$str = 'this is a test string user:testuser,anotheruser hashtag:peach,phone,milk site:youtube.com,twitter.com flair:😂bobby😂';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);