re = /^.*?(?=\s+[^:\s]+:)|([^:\s]+):([^:\s]+)/
str = 'test text user:testuser,anotheruser hashtag:peach,phone,milk site:youtube.com,twitter.com flair:😂bobby😂'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end