$re = '/(?!AA|AAA):.+?;/m';
$str = 'AA:1;AB:2;AC:3;AAA:4;AAB:5;AAC:6;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);