const regex = /\b(?!AAA?:)\w+:[^;]*;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!AAA?:)\\w+:[^;]*;', 'gm')
const str = `AA:1;AB:2;AC:3;AAA:4;AAB:5;AAC:6;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}