import Foundation
let pattern = #"(<h\d>.*?<\/h\d>)|(Lore.+?\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<h2>ipsum Lorems dolor sit amet</h2>
<p>Loremi ipsum dolor sit amet</p>
<p>Loremis ipsum dolor sit amet</p>
<h3>Lorem ipsum dolor sit amet</h3>
<p>Lorem ipsum dolor sit amet</p>
<p>Lorem ipsum dolor sit amet</p>
<p>Lorem ipsum dolor sit amet</p><h4>Lorem ipsum dolor sit amet</h4><p>Lorem ipsum dolor sit amet</p><p>Lorem ipsum dolor sit amet</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)