$re = '/{start}([\s\S]*){end}/m';
$str = '{start}
Line 1
Line 2
Line 3
{end}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);