$re = '/\d(?=[^\d\n]*$)/m';
$str = '00.00.001_
00.00.0011';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);