using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[\dAEIOUaeiouАОИЕЁЭЫУЮЯаоиеёэыуюя]{6,8}$)(\D*\d){3}.*";
string input = @"aaa123";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}