$re = '/(?:_)\K[0-9][0-9][0-9][0-9][0-9](?=_)/';
$str = 'ABC_2017_DEF_9_12_GHI_35132_S5160.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);