#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<table id="table-[0-9]+">[\s]+<tbody>[\s]+<tr><td><p>\{\{Phrase (1|2)\}\}<\/p><\/td><\/tr>[\s]+<\/tbody>[\s]+<\/table>)"
Local $sString = "<table id="table-1">" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr><td><p>{{Phrase 1}}</p></td></tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<table id="table-2">" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr><td><p>Sample text 1 goes here..</p></td></tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<table id="table-3">" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr><td><p>{{Phrase 2}}</p></td></tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<table id="table-4">" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr><td><p>Sample text 2 goes here..</p></td></tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")