const regex = /\/.*\bbacon\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/.*\\bbacon\\b', 'gm')
const str = `www.bacondelivery.com/weekly-bacon-delivery/
www.bacondelivery.com/daily-bacon-delivery/
www.bacondelivery.com/bacon-of-the-month-club/
www.bacondelivery.com/
www.bacondelivery.com/?some_param
www.bacondelivery.com/about/
www.bacondelivery.com/contact-us/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}