import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(round-trip|rtt)\\s+\\S+\\s*=\\s*([0-9.]+)/([0-9.]+)/([0-9.]+)/([0-9.]+)\\s*ms";
final String string = "1->5 packets transmitted, 5 packets received, 0.0% packet loss\n"
+ "round-trip min/avg/max/stddev = 0.067/0.078/0.087/0.007 ms\n\n"
+ "2->5 packets transmitted, 5 received, 0% packet loss, time 801ms\n"
+ "rtt min/avg/max/stddev = 0.019/0.034/0.044/0.010 ms, ipg/ewma 200.318/0.038 ms";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}