$re = '/^\b(?=\d*\D)[a-z\d @&$]+$/i';
$str = '1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);