$re = '/[a-fA-F0-9]/m';
$str = 'a 8 9 o p x c fff ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);