$re = '/\bword\b/m';
$str = 'word sumword word wordd-word 1word word_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);