package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).`)
var str = `abc ac acb aob a2b a42c a_b~/?-&*$%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}