$re = '/^\d+(\.\d+)?((E|e)(\+|-)?\d+)?$/m';
$str = '123.5e0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);