$re = '/(?<!\d)\d{5}(?!\d)/';
$str = 'Helpdesk-Agenten (m/w) Kennziffer: 12966
123456
aaa12345bbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);