re = /African(?<!South African(?= Society))/m
str = 'South African Society
South African
African Society
South African Society and African Society'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end