$re = '/(?<!South (?=African Society))African/m';
$str = 'South African Society
South African
African Society
South African Society and African Society';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);