package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(#\s#\)$`)
var str = `abcd (efghij # / klmno (# #)
blah blah etc etc words and more words and yet more words. What about these words?
And some more text for this string so that we can test things out. `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}