import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)Binding\\s+Type:\\s+0";
final String string = "LogName=Directory Service\n"
+ "SourceName=Microsoft-Windows-ActiveDirectory_DomainService\n"
+ "EventCode=2889\n"
+ "EventType=4\n"
+ "Type=Information\n"
+ "ComputerName=XXXXX\n"
+ "User=NOT_TRANSLATED\n"
+ "Sid=S-1-5-7\n"
+ "SidType=0\n"
+ "TaskCategory=LDAP Interface\n"
+ "OpCode=The operation completed successfully.\n"
+ "RecordNumber=7362133\n"
+ "Keywords=Classic\n"
+ "Message=The following client performed a SASL (Negotiate/Kerberos/NTLM/Digest) LDAP bind without requesting signing (integrity verification), or performed a simple bind over a clear text (non-SSL/TLS-encrypted) LDAP connection.\n"
+ "Client IP address:\n"
+ "1.1.11.1:5555\n"
+ "Identity the client attempted to authenticate as:\n"
+ "XXX\\XXXX\n"
+ "Binding Type:\n"
+ "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}