$re = '/{\w.*?}/m';
$str = '{test1} some test string {test2} some test string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);