package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/(?<login>.*)/(?<pass>.*)/(?<stream>.*)`)
var str = `/login/pass/1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}