$re = '/(?<=select\s)[a-zA-Z,\s__.]+(?=from)/mi';
$str = 'SELECT account.name.account,name,website,name__C (SELECT id,name from contact),(SELECT id,name from sales), from accounts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);