package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)In:.+\(([0-9\.]+%)\).+Out:.+\(([0-9\.]+%)`)
var str = `["XXXXXXX"], (up), MAC: XX:XX:XX:XX:XX:XX, Speed: 2 GBit/s, In: 0 Bit/s (0%), Out: 6.53 GBit/s (warn/crit at 1.6 GBit/s/1.8 GBit/s) (326.45%)(!!)
["XXXXXXX"], (up), MAC: XX:XX:XX:XX:XX:XX, Speed: 2 GBit/s, In: 0 Bit/s (warn/crit at 1.6 GBit/s/1.8 GBit/s) (95.45%), Out: 6.53 GBit/s (32.00%)(!!)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}