import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div[^>]*>\\d{6}<\\/div>";
final String string = "<div dir=\"ltr\"><br><br><div class=\"gmail_quote\"><div dir=\"ltr\" class=\"gmail_attr\"><br></div><u></u>\n"
+ " <div>\n"
+ " <center id=\"m_-2051398760120817894wrapper\">\n"
+ " <table id=\"m_-2051398760120817894main\" width=\"100%\">\n"
+ " <tbody><tr id=\"m_-2051398760120817894logo\">\n"
+ " <td>\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td>\n"
+ " <img src=\"test.com/logo.png\" width=\"140px\" alt=\"xxxxx Logo\" style=\"padding:0 10px\">\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td height=\"18px\"></td>\n"
+ " </tr>\n"
+ " <tr id=\"m_-2051398760120817894header\">\n"
+ " <td>\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td height=\"64px\" style=\"background-color:#10069f;color:#fff;padding-left:24px;font-weight:700\">Reset your password</td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr id=\"m_-2051398760120817894content\">\n"
+ " <td>\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td style=\"background-color:#f6f5ff;padding:24px 24px 16px 24px\">\n"
+ " <p style=\"margin-top:0\">The following is the verification code required to complete your password reset.</p>\n"
+ " <p style=\"margin-bottom:24px\">Enter the following verification code on the screen during the registration, and proceed to the next step.</p>\n"
+ " <div style=\"display:block;text-align:center;margin-bottom:8px;background-color:#fff;height:92px;font-weight:600;font-size:36px;line-height:92px\">191418</div>\n"
+ " <span style=\"display:block;font-size:12px;color:#5d5d5d\">*The verification code is valid only for 24 hours.</span>\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td height=\"24px\"></td>\n"
+ " </tr>\n"
+ " <tr id=\"m_-2051398760120817894footer\">\n"
+ " <td>\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td style=\"background-color:#6d7777;padding:16px 24px;font-size:12px;color:#fff\">\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td id=\"m_-2051398760120817894footer-left\">\n"
+ " <span style=\"display:block\">amnimo Inc.</span>\n"
+ " <span style=\"display:block\">0-3-30 usaa-fso, xxxxxxxx-shi, Tokyo, 180-8750, Japan</span>\n"
+ " <span style=\"display:block\">Phone: +81-422-52-6779</span>\n"
+ " <span id=\"m_-2051398760120817894copyright-mb\" style=\"margin-top:16px\">© 2020 <div dir=\"ltr\"><br><br><div class=\"gmail_quote\"><div dir=\"ltr\" class=\"gmail_attr\"><br></div><u></u>\n"
+ "<div>\n"
+ " <center id=\"m_-2051398760120817894wrapper\">\n"
+ " <table id=\"m_-2051398760120817894main\" width=\"100%\">\n"
+ " <tbody><tr id=\"m_-2051398760120817894logo\">\n"
+ " <td>\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td>\n"
+ " <img src=\"https://test.com/logo.png\" width=\"140px\" alt=\"Amnimo Logo\" style=\"padding:0 10px\">\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td height=\"18px\"></td>\n"
+ " </tr>\n"
+ " <tr id=\"m_-2051398760120817894header\">\n"
+ " <td>\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td height=\"64px\" style=\"background-color:#10069f;color:#fff;padding-left:24px;font-weight:700\">Reset your password</td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr id=\"m_-2051398760120817894content\">\n"
+ " <td>\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td style=\"background-color:#f6f5ff;padding:24px 24px 16px 24px\">\n"
+ " <p style=\"margin-top:0\">The following is the verification code required to complete your password reset.</p>\n"
+ " <p style=\"margin-bottom:24px\">Enter the following verification code on the screen during the registration, and proceed to the next step.</p>\n"
+ " <div style=\"display:block;text-align:center;margin-bottom:8px;background-color:#fff;height:92px;font-weight:600;font-size:36px;line-height:92px\">191418</div>\n"
+ " <span style=\"display:block;font-size:12px;color:#5d5d5d\">*The verification code is valid only for 24 hours.</span>\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td height=\"24px\"></td>\n"
+ " </tr>\n"
+ " <tr id=\"m_-2051398760120817894footer\">\n"
+ " <td>\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td style=\"background-color:#6d7777;padding:16px 24px;font-size:12px;color:#fff\">\n"
+ " <table width=\"100%\">\n"
+ " <tbody><tr>\n"
+ " <td id=\"m_-2051398760120817894footer-left\">\n"
+ " <span style=\"display:block\">test Inc.</span>\n"
+ " <span style=\"display:block\">2-9-32 ssdsa-sss, puakano-shi, Tokyo, 000-8000, Japan</span>\n"
+ " <span style=\"display:block\">Phone: +81-000-00-652</span>\n"
+ " <span id=\"m_-2051398760120817894copyright-mb\" style=\"margin-top:16px\">© 2020 amnimo Inc.</span>\n"
+ " </td>\n"
+ " <td id=\"m_-2051398760120817894footer-right\">\n"
+ " <span style=\"display:block\">© 2020 amnimo Inc.</span>\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </center>\n"
+ "</div>\n"
+ "</div></div> Inc.</span>\n"
+ " </td>\n"
+ " <td id=\"m_-2051398760120817894footer-right\">\n"
+ " <span style=\"display:block\">© 2020 test Inc.</span>\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody></table>\n"
+ " </center>\n"
+ " </div>\n"
+ " </div></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}