$re = '/.*opResult=([\w|\s]+)(\s\w+(?==).*)/';
$str = 'testest=false opResult=Critical extension not supported random=abc srcPort=10';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;