$re = '/(?:.+?(?:$|\b(?![A-Z])\w+\.))+?/m';
$str = 'Koehler rides the bus. Bowman was passed
into the first grade; Koehler advanced to third grade. Jon. Williams walked down the road to school. Bowman decided to go fishing; Koehler did not. C. Robinson asked to go to recess, and the teacher said no.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);