import Foundation
let pattern = #"^gmai|gm(aa?|s|i)(a?|u).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
g-mail.com
g.mail.com
gailmail.com
gamail.com
gaol.com
geeemail.com
gemail.com
gfmail.com
ggmail.com
gimail.com
gmai.com
gmai9l.com
gmaiil.com
gmail
gmail.
gmail..com
gmail.c
gmail.cim
gmail.cm
gmail.co
gmail.com
gmail.com.
gmail.com.com
gmail.com101
gmail.com2014505140
gmail.com8206
gmail.comalexandrasceboldsecretary
gmail.comaol.com
gmail.combchan43460
gmail.comc
gmail.comceciliaschiera
gmail.comcolecole.cc1
gmail.comi
gmail.comil.com
gmail.comj
gmail.comjamesesber
gmail.coml.com
gmail.comleponto
gmail.comll
gmail.comlwilliams102
gmail.comm
gmail.comment.com
gmail.commipg820
gmail.comn
gmail.comnaka
gmail.comnr.aidan.collins
gmail.comol.com
gmail.comorapa0013
gmail.con
gmail.coom
gmail.cpm
gmail.cvom
gmail.gmail.com
gmail.net
gmail.om
gmail.oom
gmail.you
gmail1.com
gmail8203.com
gmailc.com
gmailc.om
gmailcom
gmailfurman.com
gmaill.com
gmaillcom
gmailmgmtcom
gmails.com
gmailus.com
gmaiol.com
gmal.com
gmale.com
gmall.com
gmaol.com
gmauil.com
gmial.com
gmil.com
gmila.com
gmmail.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)