import re
regex = re.compile(r"<!--[^>]*-->", flags=re.MULTILINE)
test_str = ("<p>texto</p><!-- /* Font Definitions */ @font-face {font-family:\"Cambria Math\"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1;\n"
" mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable; mso-font-signature:0 0 0 0 0 0;} @font-face {font-\n"
" ... --><span>Mais texto</span><!-- /* Font Definitions */ @font-face {font-family:\"Cambria Math\"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1;\n"
" mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable; mso-font-signature:0 0 0 0 0 0;} @font-face {font-... -->")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)