# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!--(?>[^-]*)(?>(?!-->)-[^-]*)*-->//gm;t' <<< "<p>texto</p><!-- /* Font Definitions */ @font-face {font-family:\"Cambria Math\"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1;
mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable;
> ESSE CARACTERE AQUI QUEBRA TUDO
mso-font-signature:0 0 0 0 0 0;} @font-face {font-
... --><span>Mais texto</span><!-- /* Font Definitions */ @font-face {font-family:\"Cambria Math\"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1;
mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable; mso-font-signature:0 0 0 0 0 0;} @font-face {font-... -->"