package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Abc_\d{2})(?:_(.*))`)
var str = `Abc_01_BeispielText1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}