$re = '/^((?!http|https).)+$/m';
$str = 'http://www.domain.org
https://www.domain.org
Anything else that you wish Anything else that you wish https://www.domain.org
Anything else that you wish Anything else that you wish ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);