package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^,\r\n]*,){11}P`)
var str = `1,2,3,4,5,6,7,8,9,10,11,12,13`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}