$re = '/[^a-zA-Z\d]myspecificword[^a-zA-Z\d]/im';
$str = 'myspecificword';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);