$re = '/^([^;]*;){8}[^;]*$/m';
$str = ';asdf;asdfsadf;sdafasdf;asdfsdfasd;;;;
;asdf;asdfsadf;sdafasdf;asdfsdfasd;;;;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);