re = /^(?:\+?7|8)?(?:[\s\-(_]+)?(\d{3})(?:[\s\-_)]+)?(\d{3})(?:[\s\-_]+)?(\d{2})(?:[\s\-_]+)?(\d{2})$/m
str = '+78005553535
88005553535
8005553535
78005553535
+7(800)555-35-35
+7(800)5553535
+7(800)555 35 35
+7 (800) 555 35 35
+7 (800) 555-35-35
+7-(800)-555-35-35
8 (800) 555 35 35
800 555 35 35
800-555-35-35
8(800)5553535
8(800)555 35 35
8(800) 555-35-35
8-800-555-35-35'
subst = '$1$2$3$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result