// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ab([^_]p.*|_[^p].*|.?$)").unwrap();
let string = "ab
ab_b
ab_pm
ab_pn
c1_ab_b
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}