// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w+\s+(\d+\s+-\s+([^\-\s]+(\s+[^\-\s]+)*))(\s+-.*)?$").unwrap();
let string = "Opcao 01 - Frase aleatória - Menu Superior
Opcao 02 - Outra Frase aleatória - Menu Su
Opcao 03 - Mais 01 Frase - Menu
Opcao 04 - Mais Frase -
Opcao 05 - Frase Simples";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}