#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(youtube\()?(http:|https:)(\/\/)?((www|m)\.)?(youtube.com|youtu.be)\/(watch|embed)?(\?v=|\/)?(\S+)?"
Local $sString = "https://www.youtube.com/watch?v=DFYRQ_zQ-gk&feature=featured https://www.youtube.com/watch?v=DFYRQ_zQ-g" & @CRLF & _
"http://www.youtube.com/watch?v=DFYRQ_zQ-gk youtube(http://www.youtube.com/watch?v=DFYRQ_zQ-gk)" & @CRLF & _
"//www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"http://google.com/" & @CRLF & _
"http://youtube.com/" & @CRLF & _
"" & @CRLF & _
"https://m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"http://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"//www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/embed/DFYRQ_zQ-gk?autoplay=1" & @CRLF & _
"https://www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"https://youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://www.youtube-nocookie.com/embed/DFYRQ_zQ-gk?autoplay=1" & @CRLF & _
"https://www.youtube-nocookie.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube-nocookie.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//www.youtube-nocookie.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"www.youtube-nocookie.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"https://youtube-nocookie.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://youtube-nocookie.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//youtube-nocookie.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"youtube-nocookie.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk?t=120" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"http://youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"//youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/HamdiKickProduction?v=DFYRQ_zQ-gk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")