// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?)\. (.*?)\. (.*?)\.").unwrap();
let string = "I am a sentence. I am another sentence. Another random sentence to add to the mix. Once again I find myself writing a sentence. I hope this weekend is sunny in Brisbane. The quick brown fox jumps over the lazy dog. The cat crept into the crypt, crapped and crept out again. There are never enough hours in a day. Streaming GeorgeFM from Auckland via the bose soundtouch app is the beez kneez. For good measure, I thought I would write another sentence.
";
let substitution = "\\1. \\2. \\3.\\r\\n\\r\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}