#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{4}|\d{3} \d|\d \d{3}|\d{2} \d{2}) ([^ ]+) (.+?)(?:\s*\.*)+0,00"
Local $sString = "N° Référence Description Qté Commentaire " & @CRLF & _
"0110 481246218263 PIED REGLABLE. . . . . . . . . . 0,00 " & @CRLF & _
"0400 481010619062 CHARNIERE SUP . . . . . . . . . 0,00 " & @CRLF & _
"1 020 481010712494 PORTE CONGEL. SIX/MG 1832x590 m. 0,00 " & @CRLF & _
"10 50 481010628165 BAGUE. . . . . . . . . . . . . . 0,00 " & @CRLF & _
"10 51 481010643399 BUTEE DE PORTE right grey. . . . 0,00 " & @CRLF & _
"105 2 481010643398 BUTEE DE PORTE left grey. . . . 0,00 " & @CRLF & _
"1100 481010637390 POIGNEE. . . . . . . . . . . . . 0,00 " & @CRLF & _
"1 117 481010465600 PLAQUE SIGLE WHIRLPOOL, 2012. . 0,00 " & @CRLF & _
"1830 481010461413 TRAVERSE. . . . . . . . . . . . 0,00 " & @CRLF & _
"185 1 481010443535 PIED arriere. . . . . . . . . . 0,00 " & @CRLF & _
"1853 481010643504 COUVERCLE INFERIEUR CHARNIERE, G 0,00 " & @CRLF & _
"1880 481010616667 CHARNIERE INF . . . . . . . . . 0,00 " & @CRLF & _
"1888 481010616670 AXE CHARNIERE. . . . . . . . . . 0,00 " & @CRLF & _
"1889 481010493638 AXE CHARNIERE. . . . . . . . . . 0,00 " & @CRLF & _
"1911 481010627574 JOINT MAGNET. gris. . . . . . . 0,00 " & @CRLF & _
"2010 481010709270 CAPOT ARRIERE BLANC UF60. . . . 0,00 " & @CRLF & _
"2332 481010522421 SUPPORT BLANC 0,00 " & @CRLF & _
"2333 481010529900 SUPPORT. . . . . . . . . . . . . 0,00 " & @CRLF & _
"2334 481010529894 SUPPORT. . . . . . . . . . . . . 0,00 " & @CRLF & _
"2335 481010529897 SUPPORT. . . . . . . . . . . . . 0,00 " & @CRLF & _
"2336 481010529891 SUPPORT. . . . . . . . . . . . . 0,00 " & @CRLF & _
"2393 481010522414 RESERVE A GLACONS BLANC. . . . . 0,00 " & @CRLF & _
"2397 481010557586 RESERVE GLACONS ICE MATE. . . . 0,00 " & @CRLF & _
"2398 481010557671 FAB. DE GLACONS. . . . . . . . . 0,00 " & @CRLF & _
"2411 481010612284 TIROIR. . . . . . . . . . . . . 0,00 " & @CRLF & _
"2412 481010611725 TIROIR. . . . . . . . . . . . . 0,00 " & @CRLF & _
"2415 481010612288 TIROIR XXL. . . . . . . . . . . 0,00 " & @CRLF & _
"2416 481010609763 VOLET. . . . . . . . . . . . . . 0,00 " & @CRLF & _
"2418 481010622319 SEPARATEUR. . . . . . . . . . . 0,00 " & @CRLF & _
"2447 481010621862 CLAYETTE VERRE CONGEL . . . . . 0,00 " & @CRLF & _
"2448 481010611763 CLAYETTE VERRE. . . . . . . . . 0,00 " & @CRLF & _
"2449 481010611745 CLAYETTE VERRE. . . . . . . . . 0,00 " & @CRLF & _
"Réfrigérateur 1 porte - 850466411130 12/12/2016 " & @CRLF & _
"Réfrigérateur 1 porte - Whirlpool - Réfrigérateur 1 porte - 850466411130 - WVE26962NFX 1/3" & @CRLF & _
"" & @CRLF & _
"2458 481010622305 SUPP.BOUTEILLES 0,00 " & @CRLF & _
"2497 481010621934 PROFILE CLAYET. BLANC, 417 mm. . 0,00 " & @CRLF & _
"2614 481010620669 GUIDE GAUCHE. . . . . . . . . . 0,00 " & @CRLF & _
"2615 481010620670 GUIDE DROIT. . . . . . . . . . . 0,00 " & @CRLF & _
"2617 481010581785 SUPPORT. . . . . . . . . . . . . 0,00 " & @CRLF & _
"2618 481010583931 SUPPORT. . . . . . . . . . . . . 0,00 " & @CRLF & _
"2619 481010583984 SUPPORT. . . . . . . . . . . . . 0,00 " & @CRLF & _
"3010 481010666735 BANDEAU DE COMMANDE GRIS MG 0,00 " & @CRLF & _
"3014 481010559559 CACHE. . . . . . . . . . . . . . 0,00 " & @CRLF & _
"3560 481010639736 PLATINE COMMANDE DOTYK 2.0 TOUC. 0,00 " & @CRLF & _
"3561 481010717552 PANNEAU DE COMMANDE NOIR, UF60 . 0,00 " & @CRLF & _
"4020 481010643140 COMPRESSEUR EMD 55 CLT TL CP. . 0,00 " & @CRLF & _
"4022 480132101608 SOUPAPE. . . . . . . . . . . . . 0,00 " & @CRLF & _
"4029 480132102058 PLATEAU DEGIVR . . . . . . . . . 0,00 " & @CRLF & _
"4200 481212028055 CONDENSATEUR. . . . . . . . . . 0,00 " & @CRLF & _
"4401 481010660514 VANNE. . . . . . . . . . . . . . 0,00 " & @CRLF & _
"4409 481236058456 SOUPAPE. . . . . . . . . . . . . 0,00 " & @CRLF & _
"4410 481010721751 HELICE VENT. assy UF60. . . . . 0,00 " & @CRLF & _
"4900 481050285321 CORDON SECTEUR 2450MM,10-16A,25. 0,00 " & @CRLF & _
"4910 480132102717 CAPOT PROTECT . . . . . . . . . 0,00 " & @CRLF & _
"4913 481010553122 COUVERCLE BORNIER. . . . . . . . 0,00 " & @CRLF & _
"5210 481010638353 PLATINE CONTROLE CENTAUR UF60 A. 0,00 " & @CRLF & _
"5612 481229068325 BORNIER. . . . . . . . . . . . . 0,00 " & @CRLF & _
"5620 481010527401 FUSIBLE THERM . . . . . . . . . 0,00 " & @CRLF & _
"6140 481010643139 MONOBLOC SX.CA AE18BQ6 0,00 " & @CRLF & _
"6520 481010518293 LED. . . . . . . . . . . . . . . 0,00 " & @CRLF & _
"6521 481010512543 CACHE. . . . . . . . . . . . . . 0,00 " & @CRLF & _
"6915 480132101611 COUVRE BULBE. . . . . . . . . . 0,00 " & @CRLF & _
"6917 481231019153 SONDE. . . . . . . . . . . . . . 0,00 " & @CRLF & _
"7400 481010607739 CONDENSEUR. . . . . . . . . . . 0,00 " & @CRLF & _
"7401 481010682980 SUPPORT TUBE 0,00 " & @CRLF & _
"7430 481010627087 CAPOT ARRIERE blanc UF60 0,00 " & @CRLF & _
"7450 481010613419 ENS.EVAPORATEUR. . . . . . . . . 0,00 " & @CRLF & _
"7640 481948028144 DES091- 9 gr (6,4 x 4,85 x 2,2. 0,00 " & @CRLF & _
"Réfrigérateur 1 porte - 850466411130 12/12/2016 " & @CRLF & _
"Réfrigérateur 1 porte - Whirlpool - Réfrigérateur 1 porte - 850466411130 - WVE26962NFX 2/3" & @CRLF & _
"" & @CRLF & _
"7830 481281719208 SOUPAPE 1/4 BODY+TUBE 100MM . . 0,00 " & @CRLF & _
"7831 481010559304 TUYAU 0,00 " & @CRLF & _
"9026 481010632190 HABILLAGE DE BAC GRIS +HOT FOIL. 0,00 " & @CRLF & _
"9040 481010676921 CACHE KIT GRIS, DROIT. . . . . . 0,00 " & @CRLF & _
"9041 481010676922 CACHE KIT GRIS, GAUCHE. . . . . 0,00 " & @CRLF & _
"9042 481010643194 CACHE CHARNIERE GRIS, GAUCHE. . 0,00 " & @CRLF & _
"9043 481010643192 CACHE CHARNIERE GRIS, DROIT. . . 0,00 " & @CRLF & _
"9651 480132102378 PION. . . . . . . . . . . . . . 0,00 " & @CRLF & _
"9652 481010574993 FICHE GRIS, MG. . . . . . . . . 0,00 " & @CRLF & _
"9934 481010674836 ACCUM.DE FROID BLANC. . . . . . 0,00 " & @CRLF & _
"9991 481010535087 DOIGT. . . . . . . . . . . . . . 0,00 " & @CRLF & _
"9993 481010632442 DOIGT. . . . . . . . . . . . . . 0,00 " & @CRLF & _
"9999 481010680282 LKFINOX-Kit de juxtaposition po. 0,00 " & @CRLF & _
"Réfrigérateur 1 porte - 850466411130 12/12/2016 " & @CRLF & _
"Réfrigérateur 1 porte - Whirlpool - Réfrigérateur 1 porte - 850466411130 - WVE26962NFX 3/3" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)