$re = '/^(?!$)([a-z]*\.?[a-z]*)$/im';
$str = 'abc
a.cd
.
a
Not:
a.a.a
.a.
..
a#a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);