re = /^(?:[^:\n]*:){8}\d+\s+bytes\s(?P<BYTES>\w+\s+)/m
str = 'Nov 1 12:19:48 ASA-FW-01 : %ASA-6-302014: Teardown TCP connection 4043630532 for INSIDE-339:192.168.42.10/37308 to OUTSIDE-340:192.168.36.26/8080 duration 0:00:00 bytes 6398 TCP FINs from INSIDE-VLAN339'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end